HP just released a new version 3.51 (supercedes 3.30) of firmware for all Virtual Connect modules.

Find here the Release Notes.

Among many changes ,the new version resolves the issue described in the following Advisory:

A Virtual Connect (VC) Version 3.xx to 3.30 Firmware Update May Cause Loss of a VC Domain Configuration After a Profile Move From an Empty Bay for All Servers, and in Additional Circumstances, for Select HP Integrity Servers.

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c03057267

Other nice one is support for IE 9.0.

VCSU 1.6.0 is required for the deployment.

Happy upgrading!